Added missing files for erang-21.8.1-r1

This commit is contained in:
Ivan Panteleev 2020-04-08 15:46:37 +03:00
parent deef39c1da
commit fc53c263ea
15 changed files with 428 additions and 0 deletions

View File

@ -1,3 +1,7 @@
DIST erlang-22.1.8.1.tar.gz 54973902 SHA256 ba2577d0dec9e63e917a4822c1fa243830ea41f69f2f51d7ed1cc64c0d06d612 SHA512 a86a849047d765268866543471513061b2e6fa3a3d875f11af3d91e04e57dde68a24f5655f9ef7726c10b921ea8dc1cd2002461259a3c77460d8c9d8e86d09a7 WHIRLPOOL f2a85edd74a13e7d2b3372b42845d94cd7a7a2c50af2683e413e6ee58251f040f5db41fc89e8587ec8efbec7bbc7889ffa21f7e503d58b4e990eaa898e325b3b
DIST erlang-22.1.8.tar.gz 54967877 SHA256 7302be70cee2c33689bf2c2a3e7cfee597415d0fb3e4e71bd3e86bd1eff9cfdc SHA512 4260fab3f6cd9338ca167371cd982bcf9557729e93d58c3911e485529ed8ee97089e1de3466745d21206c94276f9865ac4fddcb2803afe915494b43feda46dda WHIRLPOOL b881f27177b814fe3571eaea7f58b7befa44483c552cb2c21f6fa49ae4437cea30fb46e140c388a36bdf70d1b42c272c09f71e8a407ce2c2e1fcbc7d04f514b3
DIST erlang_doc_html_22.1.tar.gz 33824830 SHA256 3864ac1aa30084738d783d12c241c0a4943cf22a6d1d0f6c7bb9ba0a45ecb9eb SHA512 cc24927a4ff98b04d8f93fbc46bb36ffb34570521e4f31154b778dc17cf1cff60869239c26c327d7a9360c06528f9b380a302b39fa47285e50dfd4656b508202 WHIRLPOOL 5266d99af6352e88e8e124a37e98bd6fcd96e4c482f13d8591c9e790437c8c88e77011ad624b6c7514067767ed788d3b749f87b2579ed845bae4bbfbd03c9c96
DIST erlang_doc_man_22.1.tar.gz 1355169 SHA256 64f45909ed8332619055d424c32f8cc8987290a1ac4079269572fba6ef9c74d9 SHA512 4f590f82293c97529c827c042bce673e6777c577e52e0e1876a8d6c1a0dc774c09637e85e3562f9a8af44372219d57174c002cc12a9646ae015c7bb1da34c750 WHIRLPOOL b49e04edb737c05d3a1735a31ebe8e8065d62868101f189c1caab6b8d68894a63f9b896595d54fb9e66d49db5d2a3ccf33f087e7b6396e1ef4e2db6a4a769b42
DIST otp_doc_html_17.5.tar.gz 33510258 SHA256 baba1d373c1faacf4a1a6ec1220d57d0cb2b977edb74f32cd58dc786361c6cf5 SHA512 d3e455452e6d6e241c40de6e41a7b1069f8daa45c8d2340adb62f8867948261692c8465db7e288378942ebe86fd938847756992600da93aa99cb294fadcb5211 WHIRLPOOL 9657c1fd133fa713d0f30bae0394f47f43b090149ec3457a177bd9f129c052b73f1e757762ced02c1c8bcbaec294e845859b18b0e2004429e04df8e04e36cade
DIST otp_doc_html_R16B02.tar.gz 33241266 SHA256 2d54119b30c4d905b6b1298865309c3392fefb1580ad69725e997644bed04b7f SHA512 135557ee5ecd50487526712af52e3523317ce6cf0e6ea26d8c1bfcd11d55c113d378a64e6867fcc5fe45f9d02aa60d2de2839b904e6ec8909f050752207b63d9 WHIRLPOOL e0fa173a64800a268b4bac59137819cd241efe8aee72d857cddbf3270c57a6d3e810f64691961a8eb6569a4ec281de4c7e28233a6a97f25990b0b8d476462d4b
DIST otp_doc_man_17.5.tar.gz 1363320 SHA256 85b1b2a1011fc01af550f1fe9e5a599a4c5f2a35d264d2804af1d05590a857c3 SHA512 98d241aa127cfe377e5efc52284cd324713cacefc96db5992275c4f8712a9e35e43f0dbc0d2a8d58a1127fbfa3f762eb001aea1bb1c9fa82205a3d83659ad548 WHIRLPOOL b790046a449824aa02e11bef6b84a7027351edba0fffd241221e690739df30c9c692074b7354612970d8d02b3c1bccfdbd81bb988af9874d181f177ffed49e2c

View File

@ -0,0 +1,113 @@
Description: Fix constants for wxwidgets3.0
The values of wx constants can change between stable release series (and
some have between 2.8 and 3.0), but erlang seems to hardcode these values.
Author: Olly Betts <olly@survex.com>
Bug-Debian: https://bugs.debian.org/766790
Forwarded: no
Last-Update: 2014-11-25
--- a/lib/wx/include/wx.hrl
+++ b/lib/wx/include/wx.hrl
@@ -767,7 +767,7 @@
% From "checkbox.h"
-define(wxCHK_ALLOW_3RD_STATE_FOR_USER, 8192).
-define(wxCHK_3STATE, 4096).
--define(wxCHK_2STATE, 0).
+-define(wxCHK_2STATE, 16384).
% From "checkbox.h": wxCheckBoxState
-define(wxCHK_UNCHECKED, 0).
-define(wxCHK_CHECKED, 1).
@@ -1014,10 +1014,10 @@
-define(wxSIZE_AUTO_WIDTH, 1).
-define(wxSETUP, 131072).
-define(wxMORE, 65536).
--define(wxHELP, 32768).
--define(wxRESET, 16384).
--define(wxBACKWARD, 8192).
--define(wxFORWARD, 4096).
+-define(wxHELP, 4096).
+-define(wxRESET, 32768).
+-define(wxBACKWARD, 16384).
+-define(wxFORWARD, 8192).
-define(wxICON_MASK, (16#00000100 bor 16#00000200 bor 16#00000400 bor 16#00000800)).
-define(wxICON_ASTERISK, ?wxICON_INFORMATION).
-define(wxICON_STOP, ?wxICON_HAND).
@@ -1049,8 +1049,8 @@
-define(wxTC_TOP, 0).
-define(wxTC_FIXEDWIDTH, 32).
-define(wxTC_RIGHTJUSTIFY, 16).
--define(wxSP_WRAP, 8192).
--define(wxSP_ARROW_KEYS, 4096).
+-define(wxSP_WRAP, 32768).
+-define(wxSP_ARROW_KEYS, 16384).
-define(wxSP_VERTICAL, ?wxVERTICAL).
-define(wxSP_HORIZONTAL, ?wxHORIZONTAL).
-define(wxSB_VERTICAL, ?wxVERTICAL).
@@ -1071,8 +1071,8 @@
-define(wxCB_SIMPLE, 4).
-define(wxLB_INT_HEIGHT, 2048).
-define(wxLB_HSCROLL, ?wxHSCROLL).
--define(wxLB_ALWAYS_SB, 1024).
--define(wxLB_NEEDED_SB, 512).
+-define(wxLB_ALWAYS_SB, 512).
+-define(wxLB_NEEDED_SB, 0).
-define(wxLB_OWNERDRAW, 256).
-define(wxLB_EXTENDED, 128).
-define(wxLB_MULTIPLE, 64).
@@ -1548,7 +1548,7 @@
-define(wxUPDATE_UI_FROMIDLE, 2).
% From "dialog.h"
-define(wxDEFAULT_DIALOG_STYLE, (?wxCAPTION bor ?wxSYSTEM_MENU bor ?wxCLOSE_BOX)).
--define(wxDIALOG_NO_PARENT, 1).
+-define(wxDIALOG_NO_PARENT, 32).
% From "dirctrlg.h"
-define(wxDIRCTRL_DIR_ONLY, 16).
-define(wxDIRCTRL_SELECT_FIRST, 32).
@@ -3728,7 +3728,7 @@
-define(wxSTC_KEY_LEFT, 302).
-define(wxSTC_KEY_UP, 301).
-define(wxSTC_KEY_DOWN, 300).
--define(wxSTC_MODEVENTMASKALL, 8191).
+-define(wxSTC_MODEVENTMASKALL, 1048575).
-define(wxSTC_MULTILINEUNDOREDO, 4096).
-define(wxSTC_MOD_BEFOREDELETE, 2048).
-define(wxSTC_MOD_BEFOREINSERT, 1024).
@@ -3810,7 +3810,7 @@
-define(wxSTC_INDIC_TT, 2).
-define(wxSTC_INDIC_SQUIGGLE, 1).
-define(wxSTC_INDIC_PLAIN, 0).
--define(wxSTC_INDIC_MAX, 7).
+-define(wxSTC_INDIC_MAX, 31).
-define(wxSTC_CASE_LOWER, 2).
-define(wxSTC_CASE_UPPER, 1).
-define(wxSTC_CASE_MIXED, 0).
@@ -3835,7 +3835,7 @@
-define(wxSTC_CHARSET_BALTIC, 186).
-define(wxSTC_CHARSET_DEFAULT, 1).
-define(wxSTC_CHARSET_ANSI, 0).
--define(wxSTC_STYLE_MAX, 127).
+-define(wxSTC_STYLE_MAX, 255).
-define(wxSTC_STYLE_LASTPREDEFINED, 39).
-define(wxSTC_STYLE_CALLTIP, 38).
-define(wxSTC_STYLE_INDENTGUIDE, 37).
@@ -3934,9 +3934,9 @@
-define(wxTE_PROCESS_TAB, 64).
-define(wxTE_MULTILINE, 32).
-define(wxTE_READONLY, 16).
--define(wxTE_AUTO_SCROLL, 8).
+-define(wxTE_AUTO_SCROLL, 0).
-define(wxTE_NO_VSCROLL, 2).
--define(wxHAS_TEXT_WINDOW_STREAM, 0).
+-define(wxHAS_TEXT_WINDOW_STREAM, 1).
% From "textctrl.h": wxTextAttrAlignment
-define(wxTEXT_ALIGNMENT_DEFAULT, 0).
-define(wxTEXT_ALIGNMENT_LEFT, 1).
@@ -3986,7 +3986,7 @@
-define(wxDEFAULT_FRAME_STYLE, (?wxSYSTEM_MENU bor ?wxRESIZE_BORDER bor ?wxMINIMIZE_BOX bor ?wxMAXIMIZE_BOX bor ?wxCLOSE_BOX bor ?wxCAPTION bor ?wxCLIP_CHILDREN)).
-define(wxRESIZE_BORDER, 64).
-define(wxTINY_CAPTION_VERT, 128).
--define(wxTINY_CAPTION_HORIZ, 256).
+-define(wxTINY_CAPTION_HORIZ, 128).
-define(wxMAXIMIZE_BOX, 512).
-define(wxMINIMIZE_BOX, 1024).
-define(wxSYSTEM_MENU, 2048).

View File

@ -0,0 +1,5 @@
;;; erlang site-lisp configuration
(add-to-list 'load-path "@SITELISP@")
(require 'erlang-start)
(setq erlang-root-dir "/usr/share")

View File

@ -0,0 +1,2 @@
#arguments for run erlang
command_args="-relaxed_command_check -address 127.0.0.1"

View File

@ -0,0 +1,2 @@
#arguments for run erlang
command_args="-address 127.0.0.1"

View File

@ -0,0 +1,26 @@
#!/sbin/openrc-run
# Copyright 2010-2019 Gentoo Authors
# Distributed under the terms of the Apache License, Version 2.0
ZT_ADDRESS=""
pidfile="/var/run/epmd.pid"
command_args="-daemon -relaxed_command_check -address 127.0.0.1"
depend() {
need net.lo
before sshd
}
start() {
ebegin "Starting Erlang Port Mapper Daemon"
start-stop-daemon --start --quiet \
--pidfile $pidfile \
--exec /usr/bin/epmd -- $command_args
eend $?
}
stop() {
ebegin "Stopping Erlang Port Mapper Daemon"
/usr/bin/epmd -kill >/dev/null
eend $?
}

View File

@ -0,0 +1,23 @@
#!/sbin/openrc-run
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the Erlang Public License 1.1
name="Erlang Port Mapper Daemon"
command="/usr/bin/epmd"
command_user="epmd"
command_group="epmd"
command_background=yes
pidfile="/var/run/epmd.pid"
depend() {
need net.lo
before sshd
}
stop() {
ebegin "Stopping ${name}"
${command} -kill >/dev/null
eend $?
}

View File

@ -0,0 +1,9 @@
[Unit]
Description=Erlang Portmapper Daemon
Wants=network.target
[Service]
ExecStart=/usr/bin/epmd
[Install]
WantedBy=multi-user.target

View File

@ -0,0 +1,11 @@
[Unit]
Description=Erlang Portmapper Daemon
Wants=network.target
[Service]
ExecStart=/usr/bin/epmd
User=epmd
Group=epmd
[Install]
WantedBy=multi-user.target

View File

@ -0,0 +1,42 @@
From 69043168302ec7c0bcfaa8b1fb56bfae500bd139 Mon Sep 17 00:00:00 2001
From: Nick Sarnie <commendsarnex@gmail.com>
Date: Sun, 8 Apr 2018 16:11:55 -0400
Subject: [PATCH] Don't ignore LDFLAGS
Bug: https://bugs.gentoo.org/263129
Signed-off-by: Nick Sarnie <commendsarnex@gmail.com>
---
lib/megaco/src/flex/Makefile.in | 2 +-
lib/odbc/c_src/Makefile.in | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/megaco/src/flex/Makefile.in b/lib/megaco/src/flex/Makefile.in
index c37ad4d702..400024ca0c 100644
--- a/lib/megaco/src/flex/Makefile.in
+++ b/lib/megaco/src/flex/Makefile.in
@@ -66,7 +66,7 @@ endif
CC = $(DED_CC)
CFLAGS_MT = $(CFLAGS) $(DED_THR_DEFS)
LD = $(DED_LD)
-LDFLAGS = $(DED_LDFLAGS)
+LDFLAGS += $(DED_LDFLAGS)
LEX = @LEX@
LEXLIB = @LEXLIB@
PERL = @PERL@
diff --git a/lib/odbc/c_src/Makefile.in b/lib/odbc/c_src/Makefile.in
index 784e73c47e..51c023f710 100644
--- a/lib/odbc/c_src/Makefile.in
+++ b/lib/odbc/c_src/Makefile.in
@@ -82,7 +82,7 @@ CC = @CC@
CFLAGS = $(TYPEFLAGS) @CFLAGS@ @THR_DEFS@ @DEFS@
EI_LDFLAGS = -L$(EI_ROOT)/obj$(TYPEMARKER)/$(TARGET)
LD = @LD@
-LDFLAGS = $(ODBC_LIB) $(EI_LDFLAGS)
+LDFLAGS += $(ODBC_LIB) $(EI_LDFLAGS)
LIBS = @LIBS@ @THR_LIBS@ $(EI_LIB)
INCLUDES = -I. $(ODBC_INCLUDE) $(EI_INCLUDE)
TARGET_FLAGS = @TARGET_FLAGS@
--
2.17.0

View File

@ -0,0 +1,27 @@
This is a forward port of erlang-20.3.2-dont-ignore-LDFLAGS.patch
Anthony G. Basile <blueness@gentoo.org>
diff -Naur otp-OTP-22.0.orig/lib/megaco/src/flex/Makefile.in otp-OTP-22.0/lib/megaco/src/flex/Makefile.in
--- otp-OTP-22.0.orig/lib/megaco/src/flex/Makefile.in 2019-05-10 12:42:49.000000000 +0000
+++ otp-OTP-22.0/lib/megaco/src/flex/Makefile.in 2019-06-04 15:53:37.899372564 +0000
@@ -47,7 +47,7 @@
CC = @DED_CC@
CFLAGS_MT = $(CFLAGS) @DED_THR_DEFS@
LD = @DED_LD@
-LDFLAGS = @DED_LDFLAGS@
+LDFLAGS += @DED_LDFLAGS@
LEX = @LEX@
LEXLIB = @LEXLIB@
PERL = @PERL@
diff -Naur otp-OTP-22.0.orig/lib/odbc/c_src/Makefile.in otp-OTP-22.0/lib/odbc/c_src/Makefile.in
--- otp-OTP-22.0.orig/lib/odbc/c_src/Makefile.in 2019-05-10 12:42:49.000000000 +0000
+++ otp-OTP-22.0/lib/odbc/c_src/Makefile.in 2019-06-04 15:53:37.900372572 +0000
@@ -82,7 +82,7 @@
CFLAGS = $(TYPEFLAGS) @CFLAGS@ @THR_DEFS@ @DEFS@
EI_LDFLAGS = -L$(EI_ROOT)/obj$(TYPEMARKER)/$(TARGET)
LD = @LD@
-LDFLAGS = $(ODBC_LIB) $(EI_LDFLAGS)
+LDFLAGS += $(ODBC_LIB) $(EI_LDFLAGS)
LIBS = @LIBS@ @THR_LIBS@ $(EI_LIB)
INCLUDES = -I. $(ODBC_INCLUDE) $(EI_INCLUDE)
TARGET_FLAGS = @TARGET_FLAGS@

View File

@ -0,0 +1,15 @@
https://bugs.gentoo.org/705500
https://github.com/erlang/otp/pull/2508
--- a/lib/asn1/src/Makefile
+++ b/lib/asn1/src/Makefile
@@ -190,7 +190,8 @@ asn1rtt_%.$(EMULATOR): asn1rtt_%.erl
$(V_ERLC) +debug_info $<
$(EVAL_CT_MODULES:%=%.erl): prepare_templates.$(EMULATOR) \
- $(EBIN)/asn1ct_rtt.$(EMULATOR)
+ $(EBIN)/asn1ct_rtt.$(EMULATOR) \
+ $(EBIN)/asn1ct_func.$(EMULATOR)
#
# Dependencies

View File

@ -0,0 +1,45 @@
https://github.com/erlang/otp/pull/2503
From 9fad0c9b71808458e857cbd3871cf80f46a75af1 Mon Sep 17 00:00:00 2001
From: Sergei Trofimovich <slyfox@gentoo.org>
Date: Tue, 14 Jan 2020 23:15:01 +0000
Subject: [PATCH] ei_portio.h: avoid ODR violation of
'ei_default_socket_callbacks'
Noticed as a build failure against fresh gcc-master:
```
LD otp/lib/erl_interface/bin/x86_64-unknown-linux-gnu/erl_call
ld: otp/lib/erl_interface/obj/x86_64-unknown-linux-gnu/libei.a(eirecv.o):otp/lib/erl_interface/src/misc/ei_portio.h:50: multiple definition of `ei_default_socket_callbacks'; otp/lib/erl_interface/obj/x86_64-unknown-linux-gnu/libei.a(ei_connect.o):otp/lib/erl_interface/src/misc/ei_portio.h:50: first defined here
ld: otp/lib/erl_interface/obj/x86_64-unknown-linux-gnu/libei.a(send.o):otp/lib/erl_interface/src/misc/ei_portio.h:50: multiple definition of `ei_default_socket_callbacks'; otp/lib/erl_interface/obj/x86_64-unknown-linux-gnu/libei.a(ei_connect.o):otp/lib/erl_interface/src/misc/ei_portio.h:50: first defined here
ld: otp/lib/erl_interface/obj/x86_64-unknown-linux-gnu/libei.a(send_reg.o):otp/lib/erl_interface/src/misc/ei_portio.h:50: multiple definition of `ei_default_socket_callbacks'; otp/lib/erl_interface/obj/x86_64-unknown-linux-gnu/libei.a(ei_connect.o):otp/lib/erl_interface/src/misc/ei_portio.h:50: first defined here
ld: otp/lib/erl_interface/obj/x86_64-unknown-linux-gnu/libei.a(epmd_port.o):otp/lib/erl_interface/src/misc/ei_portio.h:50: multiple definition of `ei_default_socket_callbacks'; otp/lib/erl_interface/obj/x86_64-unknown-linux-gnu/libei.a(ei_connect.o):otp/lib/erl_interface/src/misc/ei_portio.h:50: first defined here
ld: otp/lib/erl_interface/obj/x86_64-unknown-linux-gnu/libei.a(ei_portio.o):otp/lib/erl_interface/src/misc/ei_portio.h:50: multiple definition of `ei_default_socket_callbacks'; otp/lib/erl_interface/obj/x86_64-unknown-linux-gnu/libei.a(ei_connect.o):otp/lib/erl_interface/src/misc/ei_portio.h:50: first defined here
collect2: error: ld returned 1 exit status
make[3]: *** [x86_64-unknown-linux-gnu/Makefile:669: otp/lib/erl_interface/bin/x86_64-unknown-linux-gnu/erl_call] Error 1
```
The failure looks legitimate: `ei_default_socket_callbacks` is a
struct defined in 'ei_portio.h' and in 'ei_portio.c'.
The change flips 'ei_portio.h' definition to declaration.
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
---
lib/erl_interface/src/misc/ei_portio.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/lib/erl_interface/src/misc/ei_portio.h
+++ b/lib/erl_interface/src/misc/ei_portio.h
@@ -47,7 +47,7 @@ int ei_writev_fill_ctx_t__(ei_socket_callbacks *cbs, void *ctx, const struct iov
int ei_socket_callbacks_have_writev__(ei_socket_callbacks *cbs);
#endif
-ei_socket_callbacks ei_default_socket_callbacks;
+extern ei_socket_callbacks ei_default_socket_callbacks;
#define EI_FD_AS_CTX__(FD) \
((void *) (long) (FD))
--
2.25.0

View File

@ -0,0 +1,90 @@
From 04ace92c33a699f75445dc99c30d521311aba826 Mon Sep 17 00:00:00 2001
From: Steve Arnold <nerdboy@gentoo.org>
Date: Mon, 6 Aug 2018 16:38:30 -0700
Subject: [PATCH] Add daemon-mode pid file creation when not configured for
systemd
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
---
erts/epmd/src/epmd.c | 39 ++++++++++++++++++++++++++++++++++++++-
erts/epmd/src/epmd.h | 3 +++
2 files changed, 41 insertions(+), 1 deletion(-)
diff --git a/erts/epmd/src/epmd.c b/erts/epmd/src/epmd.c
index 44e997e609..c74888a1ee 100644
--- a/erts/epmd/src/epmd.c
+++ b/erts/epmd/src/epmd.c
@@ -40,6 +40,37 @@ static int check_relaxed(void);
#ifdef __WIN32__
static int has_console(void);
#endif
+#ifndef HAVE_SYSTEMD_DAEMON
+static int create_pidfile(void);
+static const char *pidfile = EPMD_PIDFILE;
+#endif
+
+#ifndef HAVE_SYSTEMD_DAEMON
+static int create_pidfile(void)
+{
+ int fd;
+
+ unlink(pidfile);
+
+ /* open the pidfile */
+ fd = open(pidfile, O_WRONLY|O_CREAT|O_EXCL, 0644);
+ if (fd >= 0) {
+ FILE *f;
+
+ /* write our pid to it */
+ f = fdopen(fd, "w");
+ if (f != NULL) {
+ fprintf(f, "%d\n", getpid());
+ fclose(f);
+ /* leave the fd open */
+ return 0;
+ }
+ close(fd);
+ }
+
+ return -1;
+}
+#endif /* (no) HAVE_SYSTEMD_DAEMON */
#ifdef DONT_USE_MAIN
@@ -340,6 +371,13 @@ static void run_daemon(EpmdVars *g)
umask(0);
+#ifndef HAVE_SYSTEMD_DAEMON
+ if (create_pidfile() < 0) {
+ dbg_perror(g,"could not create pidfile %s", pidfile);
+ epmd_cleanup_exit(g,1);
+ }
+#endif /* HAVE_SYSTEMD_DAEMON */
+
for (fd = 0; fd < g->max_conn ; fd++) /* close all files ... */
close(fd);
/* Syslog on linux will try to write to whatever if we dont
@@ -614,4 +652,3 @@ static int check_relaxed(void)
char* port_str = getenv("ERL_EPMD_RELAXED_COMMAND_CHECK");
return (port_str != NULL) ? 1 : 0;
}
-
diff --git a/erts/epmd/src/epmd.h b/erts/epmd/src/epmd.h
index cffcd4ae7a..e53322acf5 100644
--- a/erts/epmd/src/epmd.h
+++ b/erts/epmd/src/epmd.h
@@ -20,6 +20,9 @@
/* The port number is defined in a makefile */
+/* The name and path to the pid file */
+#define EPMD_PIDFILE "/var/run/epmd.pid"
+
/* Definitions of message codes */
/* Registration and queries */
--
2.17.0

View File

@ -0,0 +1,14 @@
diff -ur otp-OTP-21.0.5.orig/otp_build otp-OTP-21.0.5/otp_build
--- otp-OTP-21.0.5.orig/otp_build 2018-08-10 19:02:51.000000000 +0200
+++ otp-OTP-21.0.5/otp_build 2018-08-15 23:44:59.417191209 +0200
@@ -1343,7 +1343,9 @@
do_lazy_configure "$@";
do_boot;;
autoconf)
- do_autoconf;;
+ create_lib_configure_in
+ distribute_config_helpers
+ ;;
configure)
shift;
do_configure "$@";;